Tips to prevent UEFI BIOS from trying to boot into Windows Rescue mode after installing Ubuntu 16.04?


#1

Hi,

Did the standard install of Ubuntu 16.04 on Sony Vaio (original Windows 8) laptop, installation went smoothly as usual.
How does one keep the BIOS (choose UEFI as it is supposed to be platform agnostic) from trying to go into “Windows 8 Rescue Mode”? I have searched and tried different ways but it seems Sony has hard coded BIOS to boot into Windows 8. This machine was got on “as-is” basis, without HDD.

Tried these techniques:
(1) Failure to get ubuntu to boot on Sony Vaio Pro
https://ubuntuforums.org/…
(2) Sony Vaio Ubuntu installation won’t boot afterwards
https://askubuntu.com/que…
(3) UEFI still boots directly into Windows 8 instead of GRUB
https://ubuntuforums.org/…
(4) General UEFI install Info (not for Macs)
https://ubuntuforums.org/…
(5) Sony Vaio Pro won’t Boot into Ubuntu
https://linustechtips.com…

Thank you for suggestions!


#2

Both OS are installed in the same mode right? Both EFI? This reminds me of the trouble I ran into setting up dual boot with Ubuntu and Windows 10 on a Thinkpad X230. Got it working and I think it was the same mode issue that did it.


#3

Can you boot while holding the SHIFT key and get into Grub? I just did a quick Google and see what you mean about Sony. Maybe it is totally locked down.


#4

(1) Tried pressing the “Shift” key while booting, it just wants to go into “Your VAIO failed to start Windows”.
(2) The original Windows was installed in “Legacy” BIOS, hence changed it to UEFI BIOS mode. Is that an issue?

Also Dells seem to be the most Linux friendly of major manufacturers, as they have options to have either Windows or Linux. And Dells never gave trouble installing Linux; they seem to last forever, a Windows 2000 Dell is still in good order.


#5

Have you tried Step 7 here?

https://ubuntuforums.org/showthread.php?t=2227580

Although if you can’t get in to windows that won’t help.

Can you install Ubuntu in legacy Bios mode also? Worth a try as that was the original setup for Windows.


#6

This tool always works for me.
https://help.ubuntu.com/community/Boot-Repair


#7

Thank you @toma!


#8

Did it work for you too?


#9

Tried it, didn’t work, but best (path of least resistance) is to revert back the Sony VAIO to Windows and install Linux on another AMD machine or install Linux in Legacy Bios (non-UEFI mode).
Never had so much trouble with Linux installs!


#10

It’s a UEFI thing, It’s a little confusing initially.


#11

Is there a reason why your heart is set on UEFI mode vs BIOS?


#12

UEFI is OS agnostic, open source and supported by all vendors, any other pros-cons appreciated.


#13

OS agnostic would mean that it doesn’t favour one OS over another … I think it fails here.
Can you get a copy of the UEFI source code, recompile it and install the fixed binary? If not, then it’s not really Open Source.
I guess that just leaves ‘well supported’.
Drop the Sony support site and see if your model has a UEFI update that fixes the problem.
If that fails, then file a bug report with Sony.
Or switch to the old - fashioned BIOS.


#14

One other possible approach would be changing the partition type to set your Linux boot partition to be the ‘Windows Rescue partition’. This might cause the Sony to ‘fall back’ to your preferred OS.
Linux mostly only pays lip service to the partition type byte.


#15

That’s a great idea, Thanks!
By installing Linux on another machine, I avoided the problem.
It seems other users also have had similar issues with Sony Vaio.