Laser issues: Image won't download to Laser for engraving

We did some experiments to solve this issue. I’ll give you a recap of what we found.

Problem: Image was not working for engraving. We tried a number of different file sizes and types:

Jpg ~1.1mb
Jpg ~2mb
Jpg ~614kb
Gif b&w file exported from Photoshop
And a few others.

I exported a jpg to engrave the other day and it worked fine- the same file won’t export to the laser cutter today for some reason.

We reset the computer, the raspberry pie and the laser cutter as well. Still no luck.

Any ideas what I’m doing wrong or what the issue might be?

1 Like

Do you get an error of some kind, or any indication that it did or didn’t work?

You could double check that the ‘communication mode’ in the upper right of laserCAD is set to Redsail laser.

Have you tried someone else’s file that we know works? I’m wondering about photoshop settings.

Also please post a screenshot of error you get.

I’ll be in tonight, and take a look.

It just didn’t beep like it should on the laser cutter after the file was completely uploaded. One time it beeped after downloading the file and then the same file didn’t work another time. So it seems like a memory issue of some sort?

Yes it was in the right communication mode as we checked that

I tried the file I know works from the other night, we could try others of course. This was the result of the engraving from the other night, same file isn’t working now.

(Sorry it looks like my photo I tried to attach to this msg from my phone isn’t there)

1 Like

sounds good - sorry not sure what more I can add. maybe a question of laser cutter committee. Also wondering about memory.

Was the engrave positioned right against an edge of the bed in the program? I’ve seen problems with that.

No problem there, we tried multiple positions. One time it did work, which was an image that was brought into the software, then further reduced in size by using dithering of some sort, then the laser cutter beeped as usual but things didn’t quite add up- for instance we tried the same thing moments later and it wouldn’t “beep” so I’m not sure if it was the software or the laser cutter but my guess is it had to do with the memory but not sure how.

Ok so I think I figured out how to do it- I may be wrong but in case this solved it and someone in the future comes across a similar issue: after pressing the “download” button to upload to the laser cutter, I clicked “format” then “download to printer” and as far as I can tell this purged the memory and allowed the laser cutter to accept my image file for engraving.

1 Like

This ought be added to out wiki