Java Maven question


#1

I’m using Eclipse to build a Java project or two. Several use Opengl 3d graphics via jogamp, which has native libraries (dll/so/etc) that seem to link at runtime OK.

I tried to add JInput for joystick support. I figure copy the jogamp stuff, change the relevant bits, and it should work. oh, how wrong I was. At run time the unit test JInputTest fails because the native libraries can’t be found.

Do you have any idea what I’ve done wrong? My project is here: https://github.com/MarginallyClever/robot-overlord-app. I’m trying to make sure it will work both in development and in release.

Thank you!


#2

mvn install complains about org.kabeja:kabeja:jar:0.4 … it should presumably be in local-maven-repo but that’s empty. Is there a submodule?


#3

I grabbed the Makelangelo-software and symlinked its local repo into the other project, moving along…


#4

OK, it builds (on Fedora 29 bare metal AMD64), how do I know if it works? :slight_smile:


#5

I ran the main jar (with-dependencies) and the UI seemed to work OK, it didn’t log anything.


#6

JInputTest should enumerate devices to System.out. if it fails to link you should see a java.lang.UnsatisfiedLinkError.


#7

I tried to build master and it’s having trouble with createKeyframe and renderInterpolation, maybe I caught you mid-refactor :wink:


#8

There are many non-compiling classes. They are not relevant. Eclipse seems to let me continue regardless.


#9

I really appreciate that you take time out to look at this for me. Thank you!


#10

@Arrgh any luck?