I brought the evo car share web interface back | EvoFinder.ca

If anybody here uses Evo car share, you might be interested in this.

They got rid of their web interface a while back, which really irked me. I can’t / won’t use their crappy android app, so I reverse engineered it and made a web app.

Anywho, the url is EvoFinder.ca. It works fairly well on phones through desktops. You can only view, not reserve a car. It wouldn’t be hard to add that but it opens a can of worms ethically/legally.

The API client is implemented in TypeScript here. It works in the browser and node. It should be in it’s own repo but its not. The web app code is here if anybody is interested.

I would be delighted if anybody uses it or has any feedback or anything. Bug/feature requests are welcome here.

Hopefully somebody here finds it useful!

6 Likes

That’s really cool and useful. Evo should support your project!

2 Likes

Amazing - that’s a great service @jeremypoole

1 Like

Hmm, I’m not seeing any cars right now…

But you should definitely approach evo! Using evo became too much of a pain in the ass for me to bother with when they eliminated the web interface.

No cars, even if you zoom out? It starts quite zoomed in, so sometimes you have to zoom out to see cars. I’m working on a fix for that. Now if you did zoom out and still don’t see any cars (and tried reloading the page), that’s a problem.

I checked my server logs. You are probably the one using Firefox 86/Windows 10 coming from a cipherkey.net IP address? It doesn’t look like you reloaded the page, so give that a whirl first.

If neither zooming out/reloading the page fixes it, I’ll try to replicate the bug. If you could open the inspector (CTRL + SHIFT + I) and copy any errors in the console, that would be much appreciated.

Thanks for trying it out! I also stopped using the service after the web interface was discontinued.

Nevermind, I managed to replicate the bug. I’m assuming you declined the location permission? For some reason it doesn’t seem to load the cars on first load when you decline location. Refreshing the page does fix the issue, but I will have to look into this. People see no cars and probably don’t come back.

Thanks so much for letting me know!

I allowed permission (eventually) and didn’t see any cars when I zoomed out. But now it works when I refreshed it.