Repair/replace usb port on Nexus7 - 2013 model - data transfers not working


#1

Anyone here done usb port replacement on the 2013 model of the Nexus 7? Mine will charge but can’t any get any data over the usb port, MPT, PTP, ADB nothing.

I am thinking some of the data lines from the port must be dead and looking for tips from anyone who has done it locally, Was it hard etc.

Janet, this seems like something up your alley.


#2

@hjsvhsweb I haven’t done the Nexus 7 but if it’s anything like the Nexus 3 (which I believe it is) the charging/data board replacement should be very straightforward and involve no soldering. I’m guessing you already tried cleaning it out with air/99% iso?

If still not working I’d look on ebay or aliexpress to find the usb board replacement part. I’m guess it’s separate from the mainboard.

I recently fixed an Asus tablet (pins were mashed in beyond repair on the usb) and had to desolder the USB port from that board. It was a huge pain in the ass and also required a proprietary part. So…I’d avoid messing with solder on the port itself if possible unless you are going to chuck the thing otherwise and don’t want to buy a new charging board.

I also have a nexus 7 - really great tablet and worth fixing I say.

Is your Nexus 7 2nd generation? If so - here is a teardown. https://www.ifixit.com/Teardown/Nexus+7+2nd+Generation+Teardown/16072

And…here’s a board replacement https://www.youtube.com/watch?v=oKMMYiVQTrY

I haven’t looked at the teardown but another option might be to reflow the board in the SMD oven at VHS or try a heat gun (unless the pins are mashed in cause then you are looking at a board/port replacement for sure)


#3

@hjsvhsweb did you give it a go?