My extruder for my monoprice select mini isn't heating up


#1

How can I fix this? Thanks!

Blair


#2

Hey Blair - what have you tried already? If you google there are some things out there that people suggest checking. I took a quick look and a few people mention a ribbon cable and checking that it is seated properly as well as a few other things.


#3

I really haven’t tried anything other than turning it on and trying to preheat it. Honestly, I don’t know what a ribbon cable is. I’ll have a look. Thanks for helping.


#4

I really don’t know what to do. I just see a bunch of wires. To me they look like they are connected. If I took a picture would you be able to advise me?


#5

Hey Blair. I’m sure there are some dedicated forums or documentation for the Monoprice Select Mini?

You might have better luck asking there - There will be a lot of people that have had the same issues as you, and can help you work through them.


#6

Is there a place in Vancouver that can fix it for me?


#7

Bring it down on a Tuesday night and I can look at it.
Can’t promise that I can fix it though
:slight_smile:


#8

Really? OMG! Thank you. I only went to VHS a couple of times and that was a couple of years ago. Can I still come by? And what time? I get off of work at 6pm.


#9

I can’t make it tonight. Thank you for the offer though.


#10

SteveRoy,

Would you fix my printer if I payed you? Or at least have a look at it.